Neler yeni

Siteye girişte index.html açılmıyor

ceceyo

Yeni kullanıcı
xF 1 kullanıcı
#1
Merhaba ben site ana dizinie bir adet index.html oluşturdum normalde web tarayıcıya direk domain adını yazdığınızda bu index.html açılması lazım ama bende direk xenfora foruma gidiyor ancak domainadresi.com/index.html yapınca attığım indexi görebiliyorum muhtemelen bunun çözümü forum genel ayarlarında ama tüm denemelerime rağmen çözemedim desteklerinizi bekliyorum.
 

ceceyo

Yeni kullanıcı
xF 1 kullanıcı
#3
.htaccess dosyasının içerisine aşağıdaki kodu ekleyin.

DirectoryIndex index.html[/CODE]
Kod:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>


ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
DirectoryIndex index.html

bu şekilde dediğinizi yapınca site kafayı yiyor, ana sayfaya basınca, logoya tıklayınca index,html e diyior.